How To Fix “This application is not supported” in Google Chrome

If you are trying to install a plugin in Chrome and run into a “Not Compatible” error message followed by “This application is not supported” then there is a quick and easy solution.

The full error message reads:

This application is not supported on this computer. Installation has been disabled. The following problems are detected: NPAPI plugin is required by this app.

This is because of something called NPAPI being disabled by Chrome for various reasons. Most of them good including security issues with NPAPI plugins. However if you absolutely must run an incompatible NPAPI plugin then here is how to do it.

  1. Close Chrome
  2. Right-Click on the Chrome icon
  3. Click Properties
  4. Go to the Compatibility Tab
  5. Check the box next to “Run this program in compatibility mode for:”
  6. In the drop-down menu select Windows 7
  7. Click Apply and then OK
  8. Start Chrome
  9. Download and install your plugin normally

And you’re done!

Leave a comment

Your email address will not be published. Required fields are marked *